Blog de tutoriales e información sobre la Scene de 3DS.

sábado, 24 de junio de 2017

Guía de actualización de Boot9Strap, manten tu B9S al día.

ESTE TUTORIAL ESTÁ AL DÍA EN LA FECHA 21/09/2017.


Así como pasó en su momento con arm9loaderhax, Boot9Strap se va actualizando con el pasar del tiempo, optimizando su código y añadiendo mejoras. Es necesario mantener nuestro Boot9Strap al día si queremos mantener nuestra consola y nuestro CFW (Luma3DS) al día, así como los demás payloads actuales.

Las últimas versiones de Luma3DS requieren de Boot9Strap 1.2 o superior, así que es 100% recomendable mantener al día nuestro Boot9Strap, además, es un proceso sumamente sencillo.

La versión más actual de Boot9Strap es la 1.3, que es la que se usa en este tutorial y en todos los archivos de mi blog.


Requisitos:

  • Consola de la familia Nintendo 3DS (OLD normal XL y 2DS o New normal y XL) ya con Boot9Strap. NOTA: En caso de actualmente tener arm9loaderhax, puedes migrar a la última versión Boot9Strap siguiendo ESTE TUTORIAL.
  • El pack actualizador de Boot9Strap según tu versión actual de Boot9Strap:


¿Cómo actualizo mi Boot9Strap?

  • Colocamos el pack actualizador de Boot9Strap según sea nuestro caso en la raíz de la SD de nuestra consola.
  • Introducimos nuevamente la SD en nuestra consola.
  • Iniciamos nuestra consola mientras pulsamos Start (sin soltar Start).
  • Seleccionamos la opción "SafeB9SInstaller".
  • Pulsamos la combinación de teclas que nos indica la aplicación "SafeB9SInstaller".
  • Al finalizar el proceso, pulsamos "A" para reiniciar la consola.
  • Luego de este momento si venimos de Boot9Strap 1.0 la consola arrojará el error "Unsupported launcher (argc = 0)" no se preocupen, es totalmente normal SEGUIMOS CON LOS PASOS.
  • Apagamos la consola y ponemos la SD en nuestra pc.
  • Borramos la carpeta "boot9strap", la carpeta "luma" y el archivo "boot.firm".
  • Colocamos mi pack de Luma3DS en la raíz de la SD como se indica en ESTE POST.
  • Colocamos la SD en nuestra consola, encendemos la consola normalmente y ejecutamos nuestro FBI.
  • Dentro del FBI seleccionamos la opción "SD", buscamos el archivo "boot.firm" (que sacamos de mi último pack de Luma3DS), pulsamos A sobre él y copiamos dicho archivo con la opción "Copy" (luego confirmamos pulsando A).
  • Pulsamos B para volver al menú principal y seleccionamos la opción "CTR NAND", pulsamos A sobre la opción "<current directory>" y acto seguido seleccionamos la opción "Paste" (confirmamos pulsando A).
  • Al finalizar con lo anterior apagamos la consola, RETIRAMOS LA SD, dejamos Select pulsado y encendemos (sin soltar Select).
  • Tildamos la opción "Show NAND or user string in System Settings" y opcionalmente (y recomendado) también podemos tildar la opción "Enable game patching". NOTA PARA USUARIOS DE NEW: Adicionalmente luego de activar lo anteriormente indicado movemos la opción de "New 3DS CPU" de "Off" a "Clock+L2", DEJAR TODO LO DEMÁS COMO YA ESTÁ.
  • Pulsamos START para reiniciar y aplicar los cambios, y listo, ya podremos iniciar sin SD normalmente con nuestro Luma3DS corriendo en la CTRNAND en estos casos (con todas las ventajas que esto nos trae).



Si te gusta mi trabajo y quieres donar a través de Paypal:


O, a través de Bitcoins: 1EnafWq274tJpeguBUkNUaxZ1tGKNgk2Np.

Share:

17 comentarios:

  1. ya inicie con star y el boton de encendido pero no me aparece esa opcion

    ResponderEliminar
  2. sabes, cuando hice todo esto, me metí al fbi y cuando apagué me apareció una pantalla que dice "an exception occurred
    processor: arm9
    Exception type: prefetch abort (svcBreak)
    y un monton de codigos. no sé qué hacer. hice estos pasos con 2 consolas y sólo con una me pasa.

    ResponderEliminar
    Respuestas
    1. Me pasa exactamente lo mismo, intente de todo, desfragmentar la nand, reinstalar via ctrnand 9.2.0-20U_ctrtransfer_n3ds y nada, me sigue dando error al apagar la consola, es el mismo error que la tuya

      Eliminar
  3. Buenas a todos, vengo a comentar mi problema porque estoy desesperado a ver si tienen solución:

    1. Fui a actualizar mi Old 3ds con Luma 8.0 y Boot9trap 1.2 (tenía la versión anterior Luma 7.1 y el boot9strap correspondiente)

    2. Al hacer al paso primero enciendo la consola con star para que aparezca el menú chainloader pero no aparece nada, sino que sale directamente e menú home. (con el select sí aparece el menú luma).

    3. Investigando llego a la conclusión de q carga directamente el boot.firm que puse en la nand en vez de el de la micro sd, por lo que borro éste de la nand.

    4. Ahora la consola no enciende, al apretar el botón power se enciende la luz azul y enseguida se apaga, da igual los botones que apriete.

    Hace un tiempo cambié la micro sd por una de mayor capacidad, por si tiene algo que ver, pero todo iba estupendamente. Soy bastante snoob en el tema. ¿Tiene solución? Ya no se que hacer.

    Saludos y gracias.

    ResponderEliminar
    Respuestas
    1. Es facil, verifica que tengas el luma (boot.firm) mas actual en la raiz de tu sd, y para entrar al chainloader, verifica que la carpeta luma este en la raiz de tu 3ds con su respectivo hourglass, drecrypt 9 o goodmode9

      Eliminar
    2. Buenas, en primer lugar agradecer a quienes me respondieron con anterioridad. Voy a exponer mi problema a ver como puedo solucionarlo:

      1. Tenía una old 3ds de las antiguas que tenía boot9strap en 1.0 y luma 7.5 con tarjeta de 32 gb totalmente funcional.

      2. Decidí cambiar la tarjeta por una de 64 gb copiando todo el contenido de la de 32 y vi que en principio funcionaba todo correctamente, por lo menos al encenderla aparecían todos los juegos y aplicaciones.

      3. Al intentar actualizarla a boot9strap 1.1 y luma 8.0 veo q al encender con el botón star apretado no sale el menú correspondiente sino que enciende la consola directamente. Pienso que no enciende con el boot.firm de la sd sino con el de la nand y borro éste. Lo que ocurre es que la consola deja de encender, anteriormente como digo iba correctamente, por lo que me doy cuenta de que no reconoce el boot.firm de la sd. (Sale la luz azul y enseguida se apaga)

      4. Primero pienso que algo le pasa a la consola ya que la tarjeta sd aparentaba ir bien y el ordenador tb la reconoce perfectamente, pero por aquí me indican que será cosa de la sd, por lo que pruebo con otra de prueba de 2 gb y exacto enciende perfectamente. Copio todo lo de la antigua sd en un disco duro externo y meto sólo los archivos necesarios para que encienda la 3ds y nada. Formateo la tarjeta y nada. Así que esa tarjeta no va y listo.

      5. Actualizo la consola con la tarjeta de prueba de 2gb a boot9strap 1.2 y luma 8.1. Todo bien.

      6. Cojo otra tarjeta de 32 gb para no perder los juegos y copio todo lo que tenía antiguamente dentro con los archivos correspondientes (boot9strap 1.2 y luma 8.1) y aunque enciende y va todo bien no aparecen los juegos ni aplicaciones. Me gustaría no perderlos pero sino se puede recuperar me aguantaré.

      7. El mayor problema es que ahora mismo sólo cuento con una versión muy antigua del FBI con el icono de seguridad y salud, a través de la cual intenté instalar la versión más reciente, pero la aplicación me sale como un cuadrado en negro y al abrirlo se bloquea la consola.

      Así que ahí van mis cuestiones:
      - ¿Puedo recuperar los juegos y aplicaciones de algún modo?
      - En caso de no poder ¿Qué borro de la tarjeta ya que la tengo llena pero no me aparece nada?
      - ¿Cómo borro el icono (que debería ser del FBI) en negro? (no aparece para desinstalar)
      - ¿Cómo consigo ponerme un FBI más actual?


      P.D.: Siento el tostón, yo por si algo de lo que hice sirve para las respuestas.

      Gracias!!

      Eliminar
    3. David pudiste resolver lo de tu primer inquietud? es que a mi me paso lo mismo y mi consola solo enciende el boton azul un segundo y se apaga no hace mas nada hice lo mismo que tu pero no le he encontrado solucion alguna.

      Eliminar
  4. Buenas, en primer lugar agradecer a quienes me respondieron con anterioridad. Voy a exponer mi problema a ver como puedo solucionarlo:

    1. Tenía una old 3ds de las antiguas que tenía boot9strap en 1.0 y luma 7.5 con tarjeta de 32 gb totalmente funcional.

    2. Decidí cambiar la tarjeta por una de 64 gb copiando todo el contenido de la de 32 y vi que en principio funcionaba todo correctamente, por lo menos al encenderla aparecían todos los juegos y aplicaciones.

    3. Al intentar actualizarla a boot9strap 1.1 y luma 8.0 veo q al encender con el botón star apretado no sale el menú correspondiente sino que enciende la consola directamente. Pienso que no enciende con el boot.firm de la sd sino con el de la nand y borro éste. Lo que ocurre es que la consola deja de encender, anteriormente como digo iba correctamente, por lo que me doy cuenta de que no reconoce el boot.firm de la sd. (Sale la luz azul y enseguida se apaga)

    4. Primero pienso que algo le pasa a la consola ya que la tarjeta sd aparentaba ir bien y el ordenador tb la reconoce perfectamente, pero por aquí me indican que será cosa de la sd, por lo que pruebo con otra de prueba de 2 gb y exacto enciende perfectamente. Copio todo lo de la antigua sd en un disco duro externo y meto sólo los archivos necesarios para que encienda la 3ds y nada. Formateo la tarjeta y nada. Así que esa tarjeta no va y listo.

    5. Actualizo la consola con la tarjeta de prueba de 2gb a boot9strap 1.2 y luma 8.1. Todo bien.

    6. Cojo otra tarjeta de 32 gb para no perder los juegos y copio todo lo que tenía antiguamente dentro con los archivos correspondientes (boot9strap 1.2 y luma 8.1) y aunque enciende y va todo bien no aparecen los juegos ni aplicaciones. Me gustaría no perderlos pero sino se puede recuperar me aguantaré.

    7. El mayor problema es que ahora mismo sólo cuento con una versión muy antigua del FBI con el icono de seguridad y salud, a través de la cual intenté instalar la versión más reciente, pero la aplicación me sale como un cuadrado en negro y al abrirlo se bloquea la consola.

    Así que ahí van mis cuestiones:
    - ¿Puedo recuperar los juegos y aplicaciones de algún modo?
    - En caso de no poder ¿Qué borro de la tarjeta ya que la tengo llena pero no me aparece nada?
    - ¿Cómo borro el icono (que debería ser del FBI) en negro? (no aparece para desinstalar)
    - ¿Cómo consigo ponerme un FBI más actual?


    P.D.: Siento el tostón, yo por si algo de lo que hice sirve para las respuestas.

    Gracias!!

    ResponderEliminar
  5. Necesito que alguien me ayude con mi 3ds porfaaaaaaaaaaaaaa. Si pueden ayudarme escribanme al kcorgz@hotmail.com porfavooor y les explico

    ResponderEliminar
  6. Ya teniendo boot9strap y Luma en la consola, estoy tratando actualizar con el tutorial actualizado hasta el 18 de este mes. Lo estoy siguiendo tal cual, metí los archivos de actualización de boot9 a la sd, la prendo con el start presionado y me sale Unsupported launcher (argc = 0)" ¿por qué?

    ResponderEliminar
  7. Acabo de cambiarme de arm9 a Boot9Strap con el tutorial que esta en esta pagina mi preguta es,es necesario que yo haga este tutorial? o ya en el otro tutorial tiene el Boot9Strap en su ultima versión???

    ResponderEliminar
  8. Hola quisiera preguntar si alguien sabe si se puede cambiar mi tarjeta sd ya que cuando hice la instalación lo hice en una tarjeta con muy poca memoria.

    Gracias de antemano por su ayuda!

    ResponderEliminar
  9. Tengo la version 1.2 porque al entrar presionando select me sale LUMA 8.0, hace falta que actualice el Boot9strap ? Que versión de boot9strap es esta? es mayor que 1.2 ?

    ResponderEliminar
  10. hola muchas gracias por las actualizaciones, siempre las uso y me va perfecto en cada ocasion. una duda que he tenido desde que se puede hacer lo de copiar el boot.firm en la ctrnand, tu dices"Pulsamos START para reiniciar y aplicar los cambios, y listo, ya podremos iniciar sin SD normalmente con nuestro Luma3DS corriendo en la CTRNAND en estos casos (con todas las ventajas que esto nos trae)." cuales son esas ventajas??

    ResponderEliminar
  11. Buenos dias, he decidido actualizar mi 3ds pero al comprobar la version que tengo de Luma veo que es la 6.5 ... como puedo actualizarla ?
    gracias

    ResponderEliminar

¡Donativos!

¡Donativos!
También puedes donar con Bitcoins: 1EnafWq274tJpeguBUkNUaxZ1tGKNgk2Np

Página en donde recomiendo comprar tu Flashcard:

Página en donde recomiendo comprar tu Flashcard:
Tenemos código de descuento "PW021W08". Al momento de comprar escribir en el mensaje "From ls3dscene" para que sea más fácil de identificar y recibir mejor atención.

Datos personales

Mi foto
Fanático de los gadgets. Seguidor aficionado de la Scene de 3DS. Gamer de nacimiento. Donaciones: https://paypal.me/Sinrequilorios

Me ayudaría de mucho si lees el siguiente post:

Me ayudaría de mucho si lees el siguiente post:
En este post, hablo sobre mi próxima meta y mi situación económica.

Servicio de instalación en Venezuela:

Servicio de instalación en Venezuela:
Para los que no quieren manipular su consola (o no pueden por estar en la última versión), les traigo un servicio de instalación de Boot9Strap al día dentro del territorio venezolano. OJO: No existe tal cosa como un "chip virtual" es solo por políticas de mercadolibre y para abarcar más audiencia.